Kaunas, Eiguliai, darželis, dailė, šokiai, elektronika, 486DX, LŽŪU, linux, fotografija, dviratis, automobiliai, akvariumai, žmona, dukra...

17th
DEC

Raspberry PI + USB HDD = maitinimo bėdos

Parašė dinux kategorijoje Linux

Jau antrą kartą šiais metais ir nežinia kelintą kartą per visą avietės naudojimo istoriją griūna SD kortelė. Tiesa pati pirmoji naudota, kuri, jei nemaišau buvo 2GB microSD įdėta į perėjimą, veikė pakankamai patikimai kol nebuvau priverstas pakeisti į kažką talpesnio.

Toliau sekė bent keleta 4GB kortelių, vieną iš jų (paskutinioji) buvo Kingston gamintojo.

Taigi nusipirkau vos ne pirmą pasitaikiusią, pigiausia (~11€) USB dėžutę 2.5″ SATA diskui, susikuriu boot ir root particijas (taip kaip nurodyta daryti šviežiai diegiant Archlinux’ą į avietę). Ištraukiu SD kortelę, pajungiu HDD ir… diskas nesisuka, pasirodo per silpnas maitinimas. Maitinimas HP 1A pakrovėjas. Greitai pasikuičiu stalčiuje ir randu HTC pakrovėją. Ant jo taip pat rašo 1A.

Prie HTC pakrovėjo jungiu USB dėžutės vieną iš USB (dėžutė turi dvi USB jungtis, kad būtų galima iškarto pajungti į dvi USB jungtis, tam, kad diskui užtektu srovės iš USB jungčių). Kitą jungiu į avietės USB. Pačią aveitę užmaitinu nuo HP pakrovėjo.

Viskas startuoja, bet pala… OS nesikrauna. Greitas pagooglinimas ir paaiškėja, kad kompiuteris moka startuoti tik iš SD kortelės. Taigi SD kortelė grįžta į savo vietą, bet prieš tai atsidarau boot particijoje esančią bylą /boot/cmdline.txt ir joje paredaguoju root reikšmę. Rezultate turiu tokią eilutę:

[dinux@alarmpi ~]$ cat /boot/cmdline.txt
root=/dev/sda2 rw rootwait console=ttyAMA0,115200 console=tty1 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyAMA0,115200 elevator=noop init=/usr/bin/init

Vėl jungiu. Viskas veikia, OS kraunasi. Krovimasis žymiai spartesnis nei iš SD kortelės.

Džiaugiuosi situacija gal vieną dieną.. avietė pakimba, na gal kas nutiko…, perkraunu, dar po dienos ar dviejų vėl kabo. Patikrinu log’us, matau:

usb 1-1.3: device descriptor read/64, error -71

Googlinu. Kažko labai naudingo nerandu. Nusprendžiu, kad gal tai dėl maitinimo trūkumo. Sukeičiu pakrovėjus. Dabar HP maitina diską, HTC kompiuterį. Panašu, kad bėda dingo. Bet mintis, kad viskas veikia “ant ribos” ir nelabai tvarkingai (du pakrovėjai) neduoda ramybės.

Ieškau pas kinus galingesnio maitinimo, galvoju gal vis dėlto pajungti taip vadinama industrinį 5V maitinimą, bet paskui netyčia aptinku 3.1A USB pakrovėją su dviem jungtim. Nuotraukoje parodytos dvi USB jungtis, prie vienos parašyta 2.1A prie kitos 1A. Realybėj nusipirkus šį pakrovėją šių užrašų nėra.

HDD jungiu į tą USB kur puslapyje parašyta 2.1A, avietę prie 1A.

Dabar jau sistema veikia kažkiek laiko ir galima teigti, kad viskas tikrai gerai, jokių lūžimų, jokių klaidų loguose.

Palik komentarą

  Wordpress Theme Protected By Wp Spam Blocker

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close